Menu

How do I remove the time that shows up in the Course Curriculum section on my landing page? (V2 Themes)

(V2 themes)


The time that shows up in the Course Curriculum section is based on the duration of any video lessons you have in that chapter. If you'd like to remove the time from showing, you can do so by modifying your theme code. 


To edit the theme code, go to your Theme library, click on the "Manage my themes" button in the top right, and then click on "Edit HTML/CSS". The file that we'll be working on is the "course_curriculum" file in found in the Sections folder. Each of our themes have a slightly different format so make sure you refer to the theme you have applied for your site and then comment out the code by highlighting it in the editor and pressing CTRL and / on Windows, or CMD and / on a Mac computer. This will automatically apply a <!-- and --> to each line of code.


Altitude

 

{% if chapter.duration_in_seconds > 0 %}
<p>{{ chapter.duration_in_seconds_as_time }}</p>
{% endif %}

 

Ice Cream and Horizon

 

<div class='chapter-time chapter-time'>
{{ chapter.duration_in_seconds_as_time }}
</div>

 


Note: for the Ice Cream and Horizon theme, the time for the chapter only shows if you select the "Hide chapter contents by default" option in the Page Builder. 

image


Once you have commented out the correct code, make sure to save your changes and don't forget to make a note of these changes in case you need to update your theme or you switch themes!


image




1 person has this question

I have this same problem and I tried following the step but I had no luck. Is the code supposed to go at the beginning of the course curriculum page or the end?

image

image

 

 

Hi Taiya!


Rather than adding in code you need to "comment out" what's already there to disable the curriculum. In your current theme you'll find that code at lines 23-25. Select it and then hit Command + / (on Mac) or Control + / (on Windows) to comment it out. Once you've gone to File > Save to save your changes, the course duration should be gone.


Thanks!

Catherine

Hello Catherine,


When I hit command, +, then / on my keyboard, it just made my firefox screen bigger and it didn't do anything to the code. Am I doing something wrong?


Thanks,

Taiya

Never mind haha! I figured it out - it was just command and / with no +.

Thanks for your help!

Taiya

 

Login to post a comment