Menu

Thinkific with Gandi (gandi.net) domain

Hi,


Does anyone have experience in setting up Thinkific on a custom domain with Gandi?


I can't get the non-www traffic to work. These are my settings in Thinkific:

custom site URL: www.fullstacktraining.com


In gandi I have these DNS settings:


CNAME Name: * Hostname: full-stack-training.thinkific.com.

CNAME Name: www Hostname: full-stack-training.thinkific.com.


And I also have web forwarding:

*.fullstacktraining.com Permanent forwards to https://fullstacktraining.com


The problem is that the non-www links do not work to my site:


https://fullstacktraining.com -> does not work

http://fullstacktraining.com -> does not work

https://www.fullstacktraining.com -> works

http://www.fullstacktraining.com -> works


How can I make the non-www URLs to work? Anyone has successfully done this?


Thanks.



Hi Tamas,


Happy to help!


What you'll need to do is set it up so that your bare domain (fullstacktraining.com) forwards to www.fullstacktraining.com. The best way to do this is usually via a 301 redirect - here are Gandi's instructions for setting that up.


I hope that helps, but feel free to get in touch if you have any further questions at all.


Thanks!

Catherine

Hi Catherine,


That's fine but how do I redirect https://fullstacktraining.com to https://www.fullstacktraining.com? I don't see such option.


Tamas

Hi Tamas,


If you leave the top field empty then it should redirect the bare domain.


Thanks!

Catherine

That's the way this is setup. I have got a confirmation from the domain provider that this is not something they can do. This is really disappointing though because that means that people can't access my site if they use https (which they should) and if they leave the www subdomain out.....

Hi Tamas,


Hmm that's strange because in Gandi's documentation they definitely say that you can set up forwarding of the bare domain. Unfortunately it's not something that we can control, so you may want to consider going with another domain provider. I'd definitely check with Gandi first, though, because it doesn't seem right that you can't do that.


Thanks,

Catherine

Hi,


What I mean is that they don't allow the redirection of https://fullstacktraining.com to https://www.fullstacktraining.com. The non https version works and it's already setup as I mentioned before.


Tamas

Hi,


Ah I see, sorry for the confusion there. That's a shame that Gandi doesn't support forwarding of the bare domain from https. We can't really do anything about this, but the good news is that if somebody goes to http://fullstacktraining.com it does forward to https://www.fullstacktraining.com so visitors will always end up on a secure page. I would just make sure that you're using http://fullstacktraining.com or https://www.fullstacktraining.com whenever linking people to your site.


Sorry that we can't be of more help on this occasion.


Thanks,

Catherine

I got some additional information from Gandi which I have forwarded to your support team - I hope they can resolve it.

Login to post a comment